当前位置:主页 > 股票知识 > > 正文

通达信金银K指标公式

2019-11-21 19:24 股票知识
DRAWGBK(O C,RGB(990,0,0),RGB(0,0,990),0, 配景图 ,0);
A1:=(EMA((OPEN HIGH LOW CLOSE)/4,3) EMA((OPEN HIGH LOW CLOSE)/4,6) EMA((OPEN HIGH LOW CLOSE)/4,9))/3;
A2:=(EMA((OPEN HIGH LOW CLOSE)/4,5) EMA((OPEN HIGH LOW CLOSE)/4,10) EMA((OPEN HIGH LOW CLOSE)/4,20))/3;
A3:=(EMA((OPEN HIGH LOW CLOSE)/4,7) EMA((OPEN HIGH LOW CLOSE)/4,14) EMA((OPEN HIGH LOW CLOSE)/4,28))/3;
A4:=(EMA((OPEN HIGH LOW CLOSE)/4,9) EMA((OPEN HIGH LOW CLOSE)/4,18) EMA((OPEN HIGH LOW CLOSE)/4,36))/3;
A5:=(EMA((OPEN HIGH LOW CLOSE)/4,11) EMA((OPEN HIGH LOW CLOSE)/4,22) EMA((OPEN HIGH LOW CLOSE)/4,44))/3;
A6:=(EMA((OPEN HIGH LOW CLOSE)/4,13) EMA((OPEN HIGH LOW CLOSE)/4,26) EMA((OPEN HIGH LOW CLOSE)/4,52))/3;
A7:=(EMA((OPEN HIGH LOW CLOSE)/4,21) EMA((OPEN HIGH LOW CLOSE)/4,34) EMA((OPEN HIGH LOW CLOSE)/4,68))/3;
TOWERC:=FORCAST(EMA((3*CLOSE 2*OPEN HIGH LOW)/7,3),6);
DIRECTIONMAX:=MAX(REF(TOWERC,2),REF(TOWERC,2));
DIRECTIONMIN:=MIN(REF(TOWERC,1),REF(TOWERC,1));
{银柱}
STICKLINE(TOWERC REF(TOWERC,1),TOWERC,DIRECTIONMIN,15,0),COLOR333333;
STICKLINE(TOWERC REF(TOWERC,1),TOWERC,DIRECTIONMIN,13,0),COLOR333333;
STICKLINE(TOWERC REF(TOWERC,1),TOWERC,DIRECTIONMIN,11,0),COLOR333333;
STICKLINE(TOWERC REF(TOWERC,1),TOWERC,DIRECTIONMIN,10,0),COLOR333333;
STICKLINE(TOWERC REF(TOWERC,1),TOWERC,DIRECTIONMIN,7,0),COLOR444444;
STICKLINE(TOWERC REF(TOWERC,1),TOWERC,DIRECTIONMIN,6,0),COLOR555555;
STICKLINE(TOWERC REF(TOWERC,1),TOWERC,DIRECTIONMIN,5,0),COLOR777777;
STICKLINE(TOWERC REF(TOWERC,1),TOWERC,DIRECTIONMIN,4,0),COLOR999999;
STICKLINE(TOWERC REF(TOWERC,1),TOWERC,DIRECTIONMIN,3,0),COLORBBBBBB;
STICKLINE(TOWERC REF(TOWERC,1),TOWERC,DIRECTIONMIN,2,0),COLORDDDDDD;
STICKLINE(TOWERC REF(TOWERC,1),TOWERC,DIRECTIONMIN,1,0),COLORFFFFFF;
{金柱}
STICKLINE(TOWERC =REF(TOWERC,1),TOWERC,DIRECTIONMAX,15,0),COLOR004444;
STICKLINE(TOWERC =REF(TOWERC,1),TOWERC,DIRECTIONMAX,13,0),COLOR004444;
STICKLINE(TOWERC =REF(TOWERC,1),TOWERC,DIRECTIONMAX,11,0),COLOR004444;
STICKLINE(TOWERC =REF(TOWERC,1),TOWERC,DIRECTIONMAX,10,0),COLOR004444;
STICKLINE(TOWERC =REF(TOWERC,1),TOWERC,DIRECTIONMAX,7,0),COLOR005555;
STICKLINE(TOWERC =REF(TOWERC,1),TOWERC,DIRECTIONMAX,6,0),COLOR006666;
STICKLINE(TOWERC =REF(TOWERC,1),TOWERC,DIRECTIONMAX,5,0),COLOR007777;
STICKLINE(TOWERC =REF(TOWERC,1),TOWERC,DIRECTIONMAX,4,0),COLOR009999;
STICKLINE(TOWERC =REF(TOWERC,1),TOWERC,DIRECTIONMAX,3,0),COLOR00BBBB;
STICKLINE(TOWERC =REF(TOWERC,1),TOWERC,DIRECTIONMAX,2,0),COLOR00DDDD;
STICKLINE(TOWERC =REF(TOWERC,1),TOWERC,DIRECTIONMAX,1,0),COLOR00FFFF;
{所属板块}
Z1:=STRCAT(HYBLOCK,
Z2:=STRCAT(Z1,FGBLOCK);
Z3:=STRCAT(Z2,DYBLOCK);
Z4:=STRCAT(Z3,
DRAWTEXT_FIX(ISLASTBAR,0.03,0.199,0,STRCAT(Z4,GNBLOCK)),COLORCYAN;
{DRAWTEXT_FIX(ISLASTBAR,0.03,0.99,0,STRCAT(Z4,GNBLOCK)),COLORCYAN;};