当前位置:主页 > 股票知识 > > 正文

通达信龙头擒妖指标公式源码

2019-10-18 21:14 股票知识
()提醒您,以下是:通达信龙头擒妖指标公式源码

DRAWGBK(C O,RGB(10,0,0),RGB(0,0,0),1,2,1);
XA_1:=DYNAINFO(4) 0 AND HHV(HIGH,10)/LLV(LOW,10) 1.25 AND REF(CLOSE,1) LLV(LOW,15) (HHV(HIGH,15)-LLV(LOW,15))*0.85 AND CLOSE OPEN AND CLOSE =HHV(HIGH,10);
XA_2:=IF(DATETODAY(DATE) 15000000,1,DRAWNULL);
XA_3:=EMA(CLOSE,5);
XA_4:=EMA(CLOSE,10);
XA_5:=EMA(CLOSE,14);
XA_6:=EMA(CLOSE,18);
XA_7:=EMA(CLOSE,40);
XA_8:=EMA(CLOSE,60);
XA_9:=IF(DATE 30000*500,1,DRAWNULL);
XA_10:=MAX(XA_7,XA_8);
XA_11:=CLOSE XA_10 AND XA_1 AND (CLOSE REF(HHV(HIGH,3),1)*XA_2 AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1) 0.07);
XA_12:=VOL;
XA_13:=MA(XA_12,5);
XA_14:=XA_13 XA_13 XA_12;
XA_15:=DYNAINFO(4) 0 AND HHV(HIGH,10)/LLV(LOW,10) 1.25 AND REF(CLOSE,1) (LLV(LOW,15) (HHV(HIGH,15)-LLV(LOW,15))*0.85)*XA_2 AND CLOSE OPEN AND CLOSE =HHV(HIGH,10)*XA_9;
XA_16:=(CLOSE REF(HHV(HIGH,3),1)*XA_2 AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1) 0.07)*XA_2 AND XA_15 AND XA_14;
XA_17:=DYNAINFO(4) 0 AND HHV(HIGH,10)/LLV(LOW,10) 1.25 AND REF(CLOSE,1)*XA_2 LLV(LOW,15) (HHV(HIGH,15)-LLV(LOW,15))*0.85 AND CLOSE OPEN AND CLOSE =HHV(HIGH,10);
XA_18:=(CLOSE-REF(CLOSE,1)*XA_2)/REF(CLOSE,1)*100
XA_19:=XA_17 AND XA_18;
XA_20:=DATETODAY(DATE);
XA_21:=XA_20 9344 AND XA_20 15000000;
XA_22:=(XA_11 AND XA_19)*XA_21;
XA_23:=EMA(CLOSE,5);
XA_24:=EMA(CLOSE,10);
XA_25:=EMA(CLOSE,14);
XA_26:=EMA(CLOSE,18);
XA_27:=EMA(CLOSE,40);
XA_28:=EMA(CLOSE,60);
XA_29:=MAX(MAX(MAX(MAX(MAX(XA_23,XA_4),XA_25),XA_26),XA_27),XA_28)*XA_9;
XA_30:=MIN(MIN(MIN(MIN(MIN(XA_23,XA_4),XA_25),XA_26),XA_27),XA_28)*XA_9;
XA_31:=CLOSE XA_29 AND LOW XA_30 AND (CLOSE REF(HHV(HIGH,3),1) AND (CLOSE-REF(CLOSE,1)*XA_2)/REF(CLOSE,1) 0.09);
XA_32:=FILTER(XA_31 0,0)=1;
XA_33:=DATETODAY(DATE);
XA_34:=XA_33 9350 AND XA_33 15000000;
XA_35:=XA_32*XA_34;
XA_36:=MA(REF(HHV(CLOSE,26),1),2);
XA_37:=MA(CLOSE,26);
XA_38:=POW(CLOSE-XA_37,2);
XA_39:=MA(XA_38,13);
XA_40:=SQRT(XA_39);
XA_41:=XA_37 2*XA_40;
XA_42:=REF(XA_41,1);
XA_43:=CROSS(CLOSE,XA_36) AND HIGH REF(XA_41,1) OR (CLOSE XA_36 AND CROSS(CLOSE,REF(XA_41,1))) AND CLOSE/OPEN 0.998;
XA_44:=MACD.MACD;
XA_45:=KD.K;
XA_46:=KD.D;
XA_47:=RSI.RSI1;
XA_48:=RSI.RSI3;
XA_49:=CLOSE-REF(CLOSE,1);
XA_50:=IF(XA_49 =0,XA_49,0)*XA_9;
XA_51:=IF(XA_49 0,-XA_49,0)*XA_9;
XA_52:=MEMA(XA_50,10);
XA_53:=MEMA(XA_51,10);
XA_54:=MEMA(XA_50,6);
XA_55:=MEMA(XA_51,6);
XA_56:=MA(100*XA_52/(XA_52 XA_53),10)*XA_9;
XA_57:=MA(100*XA_54/(XA_54 XA_55),6)*XA_9;
XA_58:=MA(CLOSE,5)/MA(CLOSE,10) 0.999 AND MA(CLOSE,10)/MA(CLOSE,20) 0.9847 AND MA(CLOSE,20) MA(CLOSE,60) AND REF(COUNT(MA(CLOSE,10)/MA(CLOSE,20) 1.017 OR MA(CLOSE,5)/MA(CLOSE,10) 1.017,8) =1,1) AND MA(CLOSE,20)/MA(CLOSE,60) 1.121;
XA_59:=(CLOSE-MA(CLOSE,60))/MA(CLOSE,60)*100;
XA_60:=COUNT(XA_59 35,100)
XA_61:=XA_43 AND XA_58 0 AND NOT(DYNAINFO(4)=0) AND XA_60 AND REF(COUNT(MA(CLOSE,20) MA(CLOSE,30),4)=4 AND COUNT(CLOSE MA(CLOSE,5),3) =2,1) AND VOL REF(VOL,1) AND (REF(COUNT(CLOSE OPEN,10) =6 OR COUNT(CLOSE OPEN,5) =4,1) OR CLOSE=HIGH) AND (CROSS(XA_57,XA_56) OR CROSS(XA_44,0) OR REF(COUNT(CROSS(XA_44,0),3)=1 AND XA_44 0.15 AND CLOSE/OPEN 0.989 AND CLOSE/REF(CLOSE,1) 1.03,1) OR CROSS(XA_45,XA_46) OR CROSS(XA_47,XA_48)) AND REF(CLOSE/OPEN 0.988 AND (CLOSE OPEN OR (CLOSE =OPEN AND HIGH/LOW 1.049)),1) AND HIGH/CLOSE 1.013 AND CLOSE/OPEN 1.05;
XA_62:=XA_11 XA_16 XA_19 XA_32 XA_61
XA_63:=MA(CLOSE,5) MA(CLOSE,10) AND MA(CLOSE,10) MA(CLOSE,20) AND MA(CLOSE,20) MA(CLOSE,60) AND MA(CLOSE,60) MA(CLOSE,120) AND MA(CLOSE,5) REF(MA(CLOSE,5),1);
XA_64:=CLOSE REF(CLOSE,1)*1.1-0.01;
XA_65:=HHV(HIGH,20)=HHV(CLOSE,1) AND VOL 0 AND BARSCOUNT(CLOSE)*XA_2
XA_66:=VOL/REF(VOL,1)*XA_2
XA_67:=XA_63 AND XA_64 AND XA_65 AND XA_66;
XA_68:=MA(CLOSE,5);
XA_69:=MA(CLOSE,10);
XA_70:=MA(CLOSE,20);
XA_71:=MA(CLOSE,30);
XA_72:=MA(CLOSE,60);
XA_73:=CLOSE XA_68 AND XA_68 XA_69 AND XA_69 XA_70 AND CLOSE XA_72;
XA_74:=CLOSE/REF(CLOSE,1) 1.05 AND REF(CLOSE,1)/REF(CLOSE,2) 1.05 AND CLOSE/LLV(CLOSE,10)
XA_75:=VOL/REF(VOL,1) 2 OR VOL=HHV(VOL,15);
XA_76:=CAPITAL 10000000;
XA_77:=ATAN((MA(CLOSE,5)/REF(MA(CLOSE,5),1)-1)*100)*57.299999
XA_78:=ATAN((MA(CLOSE,10)/REF(MA(CLOSE,10),1)-1)*100)*57.299999
XA_79:=ATAN((MA(CLOSE,20)/REF(MA(CLOSE,20),1)-1)*100)*57.299999
XA_80:=ATAN((MA(CLOSE,30)/REF(MA(CLOSE,30),1)-1)*100)*57.299999
XA_81:=XA_77 AND XA_78 AND XA_79 AND XA_80;
XA_82:=KDJ.K REF(KDJ.K,1)*XA_2;
XA_83:=KDJ.D REF(KDJ.D,1)*XA_2 AND KDJ.D
XA_84:=KDJ.J REF(KDJ.J,1)*XA_2;
XA_85:=XA_82 AND XA_83 AND XA_84;
XA_86:=XA_7 AND XA_74 AND XA_75 AND XA_76 AND XA_81 AND XA_85;
XA_87:=FILTER(XA_86,15)*XA_2;
XA_88:=XA_67 OR XA_87;
龙头:DATE 15000000 AND ((XA_88 AND XA_62)*XA_2 OR XA_35 OR XA_22),NODRAW,COLORRED;
STICKLINE(龙头,0,1,2,0),COLORRED;